Have A Technology Problem? Need Help? Call (800) 519_-1872

WARNING: Huge Vulnerability in Internet Explorer Affects Everybody, No Fix for XP

alert_red_400Alert! Those using Windows Internet Explorer as your preferred web browser might want to take a short break from it and consider using a different browser like Chrome or Firefox until Microsoft works out a recently-discovered vulnerability.

This zero-day security vulnerability affects versions 6 through 11 of Internet Explorer. In other words, you have one of these on your PC. Microsoft reported that hackers have been exploiting this vulnerability in a limited amount of attacks. Microsoft also revealed that the nature of this threat is caused by a remote code vulnerability in their official security advisory, which affects the way that IE accesses a file that’s been previously deleted or not properly moved.

Hackers can take advantage of this vulnerability by executing malicious code within Internet Explorer that leads them to the corrupted memory. A hacker would then create a special website for the purpose of exploiting this vulnerability and potentially take over your PC. At the time of the posting of this blog article, Microsoft has yet to release a security patch.

The best course of action you can take to safeguard your system is to stop using IE version 6 through 11 until a security patch is released. Chrome and Firefox are great alternatives and they’re free to download. In fact, there’s a running joke on the Internet that IE is the most popular software used for downloading Chrome and Firefox.

When the security patch is released, Microsoft will notify users via their regular system updates. This is one example of why it’s a good idea to always run the latest versions of your software. If you have Windows set to automatically update your system, then the security patch will be applied as soon as it’s released and you can go back to using Internet Explorer. For our managed services clients, we’ll be, testing, white listing and rolling out the update as soon as Microsoft releases it.

This IE security patch will only be available for users of Microsoft’s supported operating systems, which means that Microsoft will not release a patch for its popular Windows XP OS–despite the fact that a significant portion of the world’s computers are still running Windows XP. This is a bold move by Microsoft and it’s an example of the software giant sticking to their guns by not supporting its recently-expired operating system. If you’re choosing to stick with Windows XP, then your system will be affected by many more vulnerabilities like this in the future. You can avoid this risk by upgrading to a newer OS. TMS can help upgrade your business to a more secure system, like Windows 7 or 8.1.

Between this IE vulnerability, the recent Heartbleed bug, and all the other new security threats hitting the net and making headlines, it seems like it’s harder to stay on top of all the security issues on the Internet. Thanks to TMS’s managed IT services you don’t have to! We can remotely monitor your system for threats like this, update your software, run virus scans, and apply security patches as soon as they’re released. To get equipped with the best protection for your business, give us a call today at 1 (626) 737-2960.