Have A Technology Problem? Need Help? Call (800) 519_-1872

WordPress Flaw Leaves Sites Open to Attack

WordPress scrambles to release security fix for vulnerability

Wordpress Security

 

WordPress issued an emergency fix to the major 4.2 version of its widely-used blogging software released just last week. The hurriedly launched version 4.2.1 was in response to a zero-day flaw that put tens of millions of WordPress sites at risk.

Jouko Pynnonen, a researcher with a Finnish IT company, discovered that by using a malicious JavaScript, a would-be hacker could attack a targeted site. The vulnerability could potentially impact all sites running version 4.2 or earlier of the WordPress platform.

According to Pynnonen, the issue lies with how WordPress handles input into the comments section of a blog post. The flaw enables hackers to run JavaScript stored in the comments section that could then allow the hacker to assume administrator privileges.

Pynnonen first blogged about this vulnerability on April 26th just three days after the release of version 2.4. He described the defect as a stored Cross Site Scripting (XSS) vulnerability.

To understand how this flaw can be used, a hacker simply needs to post some basic JavaScript code in the comments field and include sufficient text to exceed more than 64K of data. Once the comment is processed by the site administrator, the code will be executed.

“If triggered by a logged-in administrator, under default settings, the attacker can leverage the vulnerability to execute arbitrary code on the server via a plugin and theme editors,” said Pynnonen in a recent blog post.

In a statement released Wednesday, WordPress stated, “This is a critical security release for all previous versions and we strongly encourage you to update your sites immediately.”

Have questions about your website security?  Contact us immediately at (800) 519-1872 or drop us an email at info@tms-tech.com.